Добавить новость на сайт
RSS
Читать нас в RSS
Статистика сайта
Наши правила
Поиск по сайту
Добро пожаловать на Информационный портал Vectormm.net! У нас вы можете найти инструкции по настройке популярных беспроводных роутеров, а так же тонкости и хитрости по работе с операционными системами Windows и Linux. Так же, вы можете общаться на нашем форуме.

Вы не авторизованы. Пожалуйста войдите на сайт, или зарегистрируйтесь!

Установка xMailserver

  1. Оффлайн

    admen

    Посетители

    Сообщений: 14

    я это первым делом проверил...
    так выдает таблицу - описания команд php...
    4 октября 2009 - 15:41 / #21
  2. Оффлайн

    admen

    Посетители

    Сообщений: 14

    при http://my.router:8080/ - показывает загрузку страници (долго), но ничего не грузиться... (
    4 октября 2009 - 19:12 / #22
  3. Оффлайн

    vector

    Администраторы

    Сообщений: 301

    Цитата: admen
    Так: /opt/share/www/lighttpd/phpxmail

    А почему тогда в lighttpd.conf указан путь к корневой папке:
    /opt/share/www

    ???
    Либо исправляйте, либо набирайте в браузере:
    http://my.router:8080/lighttpd/



    Цитата: admen
    я это первым делом проверил... так выдает таблицу - описания команд php...

    А откуда описания команд php взялись в корневой страничке lighttpd???
    У Вас бардак в настройках веб сервера.
    4 октября 2009 - 19:53 / #23
  4. Оффлайн

    KVAn

    Посетители

    Сообщений: 3

    Спасибо большое за раскрытие темы

    Но взываю Вас о помощи. Все делаю по инструкции с Вашого сайта, но на шаге:




    3. Запускаем

    /opt/etc/init.d/S43xmail start



    у меня вылезает вот что:



    [[email protected] root]$ /opt/etc/init.d/S43xmail

    start /opt/etc/init.d/S43xmail: /opt/etc/init.d/S43xmail: 20: test: Permission denied



    Подскажите пожалуйста, где подкрутить, уж очень хочется свой маленький, но нужный :) маил сервер поднять. Какие логи предоставить?

    Вобщем, кажется доигрался/доустанавливался:




    [[email protected] root]$ flashfs save && flashfs commit && flashfs enable && reboot

    /sbin/flashfs: /sbin/flashfs: 20: cat: Permission denied

    /sbin/flashfs: /sbin/flashfs: 73: [: Permission denied

    tar: Removing leading '/' from member names

    tar: /tmp/local: Unknown file type

    tar: Error exit delayed from previous errors

    /sbin/flashfs: /sbin/flashfs: 73: ls: Permission denied



    Роутер заново конфигурировать?

    думаю, что это произошло после установки по инструкции.

    А именно виноват антивирус.

    Вот, что выдает по команде



    [[email protected] root]$ ls -l

    --wxr-sr-T 0 16877 clamav 1661566579169759488 Jan 1 1970

    [[email protected] root]$ ls -l /sbin

    ?rw----r-x 0 16877 clamav 1661566579169759488 Jan 1 1970 /sbin



    Это нормально?
    Сообщение отредактировал KVAn 6 ноября 2009 - 12:49
    6 ноября 2009 - 04:16 / #24
  5. Оффлайн

    vector

    Администраторы

    Сообщений: 301

    KVAn,
    Папки /sbin и не должно быть, пишите пути полностью.
    Самый простой вариант настройки почтовика - сделать ipkg install пакетов, а потом поверх распаковать приложенный мной архив, там все дефолтные настройки сделаны.
    Дальше - по инструкции.
    7 ноября 2009 - 20:46 / #25
  6. Оффлайн

    KVAn

    Посетители

    Сообщений: 3

    Цитата: vector
    Папки /sbin и не должно быть, пишите пути полностью. Самый простой вариант настройки почтовика - сделать ipkg install пакетов, а потом поверх распаковать приложенный мной архив, там все дефолтные настройки сделаны. Дальше - по инструкции


    Большое спасибо за ответ.
    Где-то видать накосячил, поэтому пришлось резетить роутер (WL500Gp v.1)
    Но после установки - все равно не работает :(.
    Что делал по Вашей инструкции:

    ipkg install xmail

    Установилось нормально

    ipkg install clamav

    не устанавливал, это ведь не страшно? Мне кажется, что именно из-за антивируса у меня начались косяки.

    ipkg install bash

    не устанавливал, а надо?

    у меня:

    [[email protected] root]$ ipkg list

    bash - 3.2.49-1 - A bourne style shell

    bash-completion - 1.1-1 - Programmable completion for the bash shell

    Этого недостаточно?

    Далее

    nano /opt/var/MailRoot/xmail[/code]


     




    Подождав секунд 20, проверяем коннект:


    <!--code1-->
    <!--ecode1-->
    telnet localhost 25<!--code2-->

    <!--ecode2-->



    Ответ должен быть примерно следующим:


    <!--code1-->
    <!--ecode1-->
    220 mail.syte.net <[email protected]> [XMail 1.25 ESMTP Server] service ready;

    вот тут у меня совсем плохо:

    [[email protected] root]$ telnet localhost 25

    telnet: Unable to connect to remote host (127.0.0.1): Connection refused
    <!--code2-->
    и в прцессах его нет, а должен быть?

    [[email protected] root]$ ps axf

      PID TTY      STAT   TIME COMMAND

        1 ?        S      0:01 /sbin/init

        2 ?        S      0:00 [keventd]

        3 ?        RN   127:37 [ksoftirqd_CPU0]

        4 ?        S      0:00 [kswapd]

        5 ?        S      0:00 [bdflush]

        6 ?        S      0:00 [kupdated]

        7 ?        S      0:00 [mtdblockd]

       60 ?        S      0:00 telnetd

       65 ?        S      0:04 httpd vlan1

       67 ?        Ss     0:01 nas /tmp/nas.lan.conf /tmp/nas.lan.pid lan

       68 ?        S      0:00 syslogd -m 0 -O /tmp/syslog.log -S -l 7

       72 ?        S      0:00 klogd

       73 ?        S      0:01 [dnsmasq]

       74 ?        S      0:00 [khubd]

       83 ?        Ss     0:00 lpd

       85 ?        Ss     0:00 p9100d -f /dev/usb/lp0 0

       88 ?        Ss     0:00 waveservermain

       90 ?        Ss     0:00 rcamdmain

       94 ?        S      0:04 [usb-storage-0]

       95 ?        S      0:00 [scsi_eh_0]

      120 ?        Ss     0:00 infosvr br0

      121 ?        Ss     0:02 watchdog

      123 ?        Ss     0:00  _ ntp

      131 ?        S      0:00 dropbear

     1267 ?        Ss     0:01  _ dropbear

     1268 pts/0    Ss     0:00      _ -sh

     1298 pts/0    R+     0:00          _ ps axf

      144 ?        S      0:00 [kjournald]

      156 ?        Ss     0:00 /opt/sbin/cron

      165 ?        Ss     0:00 /opt/sbin/xinetd -pidfile /var/run/xinetd.pid

      180 ?        S      0:02 /opt/sbin/lighttpd -f /opt/etc/lighttpd/lighttpd.conf

      185 ?        Ss     0:00  _ /opt/bin/php-fcgi

      193 ?        S      0:00      _ /opt/bin/php-fcgi

      194 ?        S      0:00      _ /opt/bin/php-fcgi

      190 ?        Ss     0:00 /opt/sbin/smbd -D

     1020 ?        S      0:24  _ /opt/sbin/smbd -D

      192 ?        Ss     0:00 /opt/sbin/nmbd -D

    Где же ошибка, все ведь устанавливал с нуля, по инструкции?
    Если бы были логи, то показал бы, но ведь мерзавец не создает..
    Помогите пожалуйста.



    в инструкции на шаге №2 "xmail" одного содержания,
    а стой же инструкции, но в шаге №7

    "Скачиваем архив отсюда: MailRoot.zip

    Распаковываем, и заменяем файлы в /opt/var/MailRoot/ на файлы из архива"

    Какой использовать?

    тот, что в архиве, после того, как я его зделал исполняемым, запустился, на некоторое время "подвесил" роутер. После перезагрузки, на файловой структуре были ошибки. Это из-за него?



    Извините, за ниписАние, но это не моя вина - обычно я аккуратен :), просто форум жутко глючит
    8 ноября 2009 - 00:15 / #26
  7. Оффлайн

    Shushik

    Посетители

    Сообщений: 2

    А нет ли у кого русской инструкции по настройке xmail через phpxmail? Или перевода той, что на их сайте имеется...
    8 ноября 2009 - 09:56 / #27
  8. Оффлайн

    KVAn

    Посетители

    Сообщений: 3

    Спасибо vector! Все работает с Вашей инструкцией и установками из архива.
    Но на шаге №2, там, где "обрезанный" xmail действительно не запускается, лишь скопированный поверх из архива с chmod +x завелся. Это так, может инструкцию подправить для таких как я.. :)

    Скажите, а по установкам фаервола можна спросить? :)
    8 ноября 2009 - 14:43 / #28
  9. Оффлайн

    vector

    Администраторы

    Сообщений: 301

    KVAn,
    Для простоты настройки использовать архив.
    Если есть знания, как делать руками, то тогда лучше самому все настроить.
    По настройкам файерволла спрашивайте.
    Форум подглючивает иногда, пока причину не отловил.

    Shushik,
    В гугле поискать "настройка phpxmail" не пробовали? ;)
    9 ноября 2009 - 10:03 / #29
  10. Оффлайн

    Shushik

    Посетители

    Сообщений: 2

    vector Был я там, ничего конкретно по настройке не нашел... :(
    9 ноября 2009 - 19:20 / #30

Статистика форума, пользователей онлайн: 0 (за последние 20 минут)

---

Администраторы | Главные редакторы | Журналисты | Посетители | VIP

Создано тем
110
Всего сообщений
643
Пользователей
1015
Новый участник
lexChaiday
НаверхНаверх
Наверх